Board logo

标题: [安装升级] 安装时显示连接数据库出错 [打印本页]

作者: kimmy    时间: 2018-9-12 21:49     标题: 安装时显示连接数据库出错

之前我已经成功安装过2.7.3版本,但是最近下载新版4.0版。
我已经删除原本主目录资料,重新上载4.0版的文件档。
也修改了cart data等权限。

我看官方说明是支持php7.0。现在我的版本也是7.0
使用的是mysql

数据库名密码都是曾经成功安装过的资料,但是就出现创建数据库失败。
也试过重新建立新的数据库及帐户,也是出现同样问题。

完全搞不懂,请各位大大们帮帮忙。这是哪里出错了?


1.83.JPG
2018-9-12 21:01


图片附件: 1.83.JPG (2018-9-12 21:01, 39.1 KB) / 下载次数 17
http://bbs.ecshop.com/attachment.php?aid=114495&k=b78e7e69e0e10dde8b72c6bc95f62b3b&t=1547745898&sid=737h7R


作者: gezi_hui    时间: 2018-9-15 12:23

那你得先确认下你的数据库是不是正常状态
作者: jack5392    时间: 2018-9-19 23:09

請檢查你的主機數據庫帳號及密碼是否正確,另外你上傳過程是否使用二進位上傳.請檢查你的帳號是否有大小寫跟空白與標點符號.或者你可以將帳號密碼複製到記事本後再貼到你要安裝的畫面上,可以省去輸入錯誤的機率.
作者: jack5392    时间: 2018-9-19 23:11

另個就是安裝的主程式裡面的數據檔你要記的進去修改. 也有可能是安裝程式檔裡面的數據庫跟你目前使用的是不一樣. 之前我也是遇到跟你一樣的問題,才發現是安裝程式裡面的數據庫忘記更改.
作者: tanchunfeng    时间: 2018-10-5 21:14

那你得先确认下你的数据库是不是正常状态
作者: kimmy    时间: 2018-10-25 20:26

回复 5# tanchunfeng


    是正常狀態,我重新裝回2.73或3.6版本都沒問題。
唯獨4.0版出現這問題
作者: sun6    时间: 2018-12-15 15:51

估计是数据库连接信息不正确。




欢迎光临 ECOS电商系统交流论坛-Shopex开源网站官方论坛 (http://bbs.ecshop.com/) Powered by Discuz! 7.2