ECStore开源文档
ECStore帮助文档
ECshop下载 | ECshop商业授权
安装指南 | 升级指南 | 用户手册 | 在线帮助
进入论坛发帖前请先读本帖 | 常见问题
ECMall多用户商城系统
ECStore B2B2C
ECStore产品授权中心
ECShop合伙人计划-一起赚钱
ECShop最新H5模板
ECMall基础套餐(PC+H5)
ECMall3.0商业授权
返回列表 发帖

[BUG处理] [已解决] ecshop 2.7.3 兼容php高版本测试版

BUG处理

网站地址 localhost
是否整合
是否更改程序 fou
系统环境 php 5.5
ecshop 2.7.3 目前正式版本最高只兼容到 php 5.2,为了兼容其他版本的php,目前修改了程序,欢迎大家测试一下(建议放到测试站点,正式站点慎用),由于时间匆忙,未有 php 5.3和php5.4环境测试,应该有部分不兼容的而我未发现,如发现错误请截图说明,并贴url地址和说明操作,谢谢。如果后续没有发现问题,更新部分将会更新到最新版本中,让正式版兼容高版本的php。
     ecshop u2.7.3 php 5.5 测试版本:点击下载
喜欢帮助他人想申请成为版主的热心网友可PM我。
官方定制开发 咨询QQ542554970
ECShop下载                             ECShop商业授权

你终于算是冒泡了,离奇失踪数月之后的又一次离奇露面
2.74正式版什么时候能出来呢
ECShop下载                             ECShop商业授权

TOP

不容易啊,一出面就放大招
ECShop下载                             ECShop商业授权

TOP

坐等2.7.4正式发版
ECShop下载                             ECShop商业授权

TOP

牛B的人物,无时无刻不在身边

TOP

期待官方更多动作。

TOP

赞,先支持个。。。。。。。
——老杨,ecshop模板、承接一切ecshop二次开发LYECS v3.0**强体验,震撼推出

TOP

php5.2和5.3之间变化巨大.如果5.3能用,估计以上的php5系列都可以吧.
php5.3没有了Zend Optimizer,由Zend Guard代替.
图形库gd变化.
ecshop2.7.3release1106是在php5.3下写的吧?记得mobile目录里有个文件的用法是php5.3版本的.好像是引用拷贝.如:
$var=new &$something;
1

评分人数

TOP

回复 1# 晓天


    建议2.7.4也发出来吧。

TOP

回复 8# psikyo
ecshop  开发环境是 php 5.2,再高于这个版本的时候,会出一些错误,看代码是有比较多copy前面的部分。

TOP

提示: 作者被禁止或删除 内容自动屏蔽
签名被屏蔽
ECShop下载                             ECShop商业授权

TOP

本帖最后由 psikyo 于 2014-10-10 17:04 编辑

回复 10# 晓天


    我翻了一下前面我修改的笔记,ecshop2.7.3release1106版本,mobile手机版浏览时,如果php是5.3版本的,会报告这个文件的某行出错。includes/lib_debug.php
原语句这样写的:
$pa = &new Print_a_class;
搜索&new就可以很快找到出错行。
原因应该是php5.3中,不可以使用引用new对象。但是php5.2是可以这样写的。
其他不兼容错误暂时没有发现。
附录版本细节:
ECShop_V2.7.3_UTF8_release1106.rar  MD5校验码:AECA9AEDDEC603F52904FF2BB8AFC7E1
ECShop下载                             ECShop商业授权

TOP

2.7.4 正式版啊正式版..
ECShop下载                             ECShop商业授权

TOP

提示: 作者被禁止或删除 内容自动屏蔽
签名被屏蔽
ECShop下载                             ECShop商业授权

TOP

提示: 作者被禁止或删除 内容自动屏蔽
签名被屏蔽
ECShop下载                             ECShop商业授权

TOP

返回列表